ADX enforcement of TLS 1.2 version

This post has been republished via RSS; it originally appeared at: New blog articles in Microsoft Tech Community.

Change details

We are continuously updating our service to ensure security is in line with organization recommendations and company requirements. As part of the Microsoft-wide “TLS 1.2 everywhere” initiative, Azure Data Explorer will stop accepting requests made using Transport Layer Security (TLS) 1.1 or older and will require TLS 1.2.

This will affect all Azure Data Explorer APIs, including Azure Resource Manager APIs (i.e. APIs used to create Azure Data Explorer clusters and databases).

Impacted scenarios 

This will affect all applications, clients, and code that use Azure Data Explorer APIs with older TLS versions.

Required change

To avoid any service interruptions, please ensure that requests issued to Azure Data Explorer use at least TLS 1.2. 

For solving TLS 1.0 issues and more instructions please use the following links:

https://docs.microsoft.com/en-us/security/solving-tls1-problem

https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi

Schedule & plan 

TLS 1.2 enforcement roll-out - January 10, 2019

REMEMBER: these articles are REPUBLISHED. Your best bet to get a reply is to follow the link at the top of the post to the ORIGINAL post! BUT you're more than welcome to start discussions here:

This site uses Akismet to reduce spam. Learn how your comment data is processed.