Device registration fails as Company Portal installation is not detected on Jamf-managed Macs

This post has been republished via RSS; it originally appeared at: Intune Customer Success articles.

We were recently alerted to an Intune Company Portal issue whereby users would see an error in Jamf Self Service. If you run into this, there’s two options to resolve.

 

Symptoms

When users attempt to register a Jamf-managed Mac using Company Portal app v2.6 or later, users see the following error in Jamf SelfService:

 

Error: Microsoft's Company Portal.app is not installed. {com.jamf.aad.errors code=1}

 

Root Cause 

The Company Portal for macOS app’s bundle identifier has been updated in Company Portal v2.6. As a result, Jamf Pro 10.21.0 or earlier cannot detect the new bundle identifier.  

 

Resolution 

To resolve this issue, complete one of the two options below:

 

Option 1: 

Update to Jamf Pro 10.22.1 or later when using Company Portal for macOS v2.6 or laterYou can install the latest Company Portal for macOS here.

 

Option 2: 

Install Company Portal app for macOS v2.5 or earlier when using Jamf Pro 10.21.0 or earlier.

 

JAMF has published an article with similar guidance: here.

 

You can download Company Portal for macOS v2.5 here.

 

Let us know if you have any additional questions on this by replying back to this post or tagging @IntuneSuppTeam out on Twitter.

 

Blog post updates:

7/16/20: Included an option to download the Company Portal for macOS v2.5.

REMEMBER: these articles are REPUBLISHED. Your best bet to get a reply is to follow the link at the top of the post to the ORIGINAL post! BUT you're more than welcome to start discussions here:

This site uses Akismet to reduce spam. Learn how your comment data is processed.